Web Hosting Forums

Results 1 to 4 of 4

This is a discussion on Gallery says apache can't obey my .htacess in the Hosting Talk & Chit-chat forum
Apache is not obeying your .htaccess file. Try entering the following into your web server's httpd.conf file: <Directory /home/jreelfly/public_html/modules/Gallery> AllowOverride Options FileInfo </Directory> Magic quotes ...

  1. #1
    Loyal Client
    Join Date
    Apr 2004
    Posts
    6

    Gallery says apache can't obey my .htacess

    Apache is not obeying your .htaccess file. Try entering the following into your web server's httpd.conf file:


    <Directory /home/jreelfly/public_html/modules/Gallery>
    AllowOverride Options FileInfo
    </Directory>
    Magic quotes are on. Your webserver administrator can turn them off by putting :

    magic_quotes_gpc = Off
    in your php.ini file.
    Either mod_rewrite is not installed or your .htaccess file is not enabled (see above). Either way, we'll have to use longer URLs in the Gallery. If you want to turn it on, first make sure that your .htaccess file is being obeyed. If it still doesn't work, you may need to reconfigure and rebuild Apache with this flag:

    --enable-module=rewrite
    Hi, would anyone please kindly help.

    I got these 3 warnings when I run Gallery's setup. I thought the .htaccess is enabled on every directory. Why is this the case now? How do I enable .htacess again?

    Who should I contact to disable the Magic-Quotes?

    And what should I do to enable mod_rewrite?

    I'm on siberia. Thanks a million for your help.

    -zeroem

  2. #2
    Yeah, I know a LOT! Vin DSL's Avatar
    Join Date
    Mar 2003
    Location
    Arizona Uplands
    Posts
    10,661
    I only have a minute, but I wanted to say there is probably no way 'they' are going to turn off 'magic quotes' on 'your' server. If 'you' want to do it, 'you' can write it into 'your' scripts, I believe, or use .htaccess, but I don't have time to look it up right now.

    When 'magic quotes' are on, all ' (single-quotes), " (double-quotes), \ (backslashes) and NUL's are escaped with backslashes automatically. If 'they' would turn 'magic quotes' off, half the sites on 'your' server would quit working.

    Gotta run! If this isn't answered later, I'll chime back in during my lunch break, or whatever...
    DISCLAIMER Any resemblance between the views expressed above and those of the owners and operators of this system is purely coincidental. Any resemblance between these views and my own are non-deterministic. The existence of Vin DSL is questionable. The existence of views in the absence of anyone to hold them is problematic. The existence of the reader is left as an exercise in the second-order coefficient.

    No Guts, No Story! VinDSL 2010

  3. #3
    Community Leader jason's Avatar
    Join Date
    Sep 2001
    Location
    Rochester, NY
    Posts
    5,884
    Put the following in your .htaccess file, presuming you've gotten it working, to override the magic quotes issue:

    php_flag magic_quotes_gpc off

    --Jason
    Jason Pitoniak
    Interbrite Communications
    www.interbrite.com www.kodiakskorner.com

  4. #4
    Loyal Client
    Join Date
    Apr 2004
    Posts
    6

    Thanks guys.

    Thanks guys for your help.

    Yes, the problem is how to get htaccess working first. Anyone out there on a shared server have htaccess not working before but later got it working? Would you please tell me your experience?

    Jaguar support staff, would you please instruct me how to get it working?

    -zeroem

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •