Web Hosting Forums

Results 1 to 5 of 5

This is a discussion on Cannot connect to database in the Hosting Talk & Chit-chat forum
I am trying to set up PhpBB for the very first time, but I'm having a slight problem getting it to work. Database Server Hostname ...

  1. #1
    Resident Alien Sara's Avatar
    Join Date
    Aug 2002
    Posts
    397

    Cannot connect to database

    I am trying to set up PhpBB for the very first time, but I'm having a slight problem getting it to work.

    Database Server Hostname / DSN: localhost
    Your Database Name: serialpu_afps
    Database Username: serialpu_afps
    Database Password: My password

    and all the other fields filled out. But when I hit the install button it says that it cannot connect to the database.

    What am I doing wrong here?

    I'm hosted on cobra if that is on any help.

  2. #2
    04 LeeUmm's Avatar
    Join Date
    Oct 2002
    Location
    Hamilton, Ontario
    Posts
    630
    did you set up the database in the control panel?

    Did you make a user serialpu_afps for the database?

    If you just set up the database without making a specific user for it, the username is your default one that you chose when you signed up here.
    so im asuming yours would be serialpu
    Nomsane?
    That is all.

  3. #3
    Resident Alien Sara's Avatar
    Join Date
    Aug 2002
    Posts
    397
    Originally posted by whitty
    did you set up the database in the control panel?

    Did you make a user serialpu_afps for the database?

    If you just set up the database without making a specific user for it, the username is your default one that you chose when you signed up here.
    so im asuming yours would be serialpu
    Duh!! I forgot to add the user to the db eventhough it did look like it was added. (Or perhaps I'm just too new to all of this yet)

  4. #4
    Loyal Client
    Join Date
    Jan 2002
    Posts
    636
    With what you describe above, I dont see anything that would cause this to happen... just check a thing or two, first.

    1. make sure the directory where phpBB2 resides is chmod to 755

    2. make sure your db and db username (password too)were written to the install script, exactly as you set them up. (one letter, number, or blank character (space) will muck things up for ya)

    3. not real certain on this one now, but I think if you dont set the admin name and password in the installation step... may cause you grieve too.

    IF these things dont help, you may need to post a bit more specific info... so someone can help ya better.
    Good Luck

  5. #5
    Loyal Client
    Join Date
    Jan 2002
    Posts
    636
    Originally posted by Sara


    Duh!! I forgot to add the user to the db eventhough it did look like it was added. (Or perhaps I'm just too new to all of this yet)
    ahhhhh ats ok sara... classic rookie flub!

    pretty good at those myself

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •