Web Hosting Forums

Results 1 to 11 of 11

This is a discussion on CSS Not Showing Up in NS4.7 in the Hosting Talk & Chit-chat forum
I'm wondering if any of you know why NS4.7 is completely ignoring my CSS. I know it won't read all of it, but it's not ...

  1. #1
    hell no, we won't go!
    Join Date
    Sep 2002
    Posts
    1,093

    CSS Not Showing Up in NS4.7

    I'm wondering if any of you know why NS4.7 is completely ignoring my CSS. I know it won't read all of it, but it's not reading the stuff it should. Anyone have any ideas? <http://sir.cakdesign.com/>

    I'm not using fancy @import tricks or nothin...at least I think I'm not.
    - Colin

    I like food.

  2. #2
    young and idealistic clio's Avatar
    Join Date
    Oct 2002
    Location
    Tübingen, Germany
    Posts
    2,140
    css doesn't work in netscape 4.x as far as i know

    i also know that some versions of netscape, don't work CSS if you include it in a style sheet separate from your HTML page, so in all my pages, i just have the CSS in the header, no link to a CSS file.
    - Julie
    Student / Web Developer

  3. #3
    Loyal Client
    Join Date
    Jan 2002
    Posts
    636
    Originally posted by clio
    css doesn't work in netscape 4.x as far as i know

    i also know that some versions of netscape, don't work CSS if you include it in a style sheet separate from your HTML page, so in all my pages, i just have the CSS in the header, no link to a CSS file.
    Interesting tid-bit to know! Thanks you 2...

  4. #4
    hell no, we won't go!
    Join Date
    Sep 2002
    Posts
    1,093
    Originally posted by clio
    css doesn't work in netscape 4.x as far as i know
    Yeah, but the thing is my version of NS recognizes CSS linked like in the SIR page on some of my other page (for example, <http://www.cakdesign.com/>)

    Maybe if I try a hardlink?
    - Colin

    I like food.

  5. #5
    Royal pain in the @$$ timechange's Avatar
    Join Date
    Nov 2001
    Posts
    1,559
    Netscape 4.x does support CSS but not the full implementation of it.
    Hot domain auctions on ebay: http://timechange.com/ebay/

  6. #6
    Loyal Client jkeller's Avatar
    Join Date
    Feb 2002
    Location
    Paris, France
    Posts
    1,502
    Originally posted by timechange
    Netscape 4.x does support CSS but not the full implementation of it.
    Yes, indeedy. It's frustrating at times...

    Dogma: I do have some styles that successfully work, even when only present in a separate css file. What I've been able to determine is that styles (font and positioning are the two that I've tested) aren't carried down through a nested div chain. Thus, if you want a font style for text nested in more than one div, you'll have to apply that style directly to the div that contains the text.

    Not too clear, but then neither is what does and doesn't work in NS 4.x to begin with. Personally, I'm trying to remove all formatting for NS 4.x -- its uneven support messes me up because some of my elements work and some don't. So, you've already achieved the nirvana that I'm after!

  7. #7
    Tim
    Tim is offline
    Loyal Client
    Join Date
    Mar 2002
    Location
    Nevada, USA
    Posts
    152

    Re: CSS Not Showing Up in NS4.7

    Originally posted by Dogma
    I'm wondering if any of you know why NS4.7 is completely ignoring my CSS.

    I'm not using fancy @import tricks or nothin...at least I think I'm not.
    NN4 doesn't recognize the id attribute. Change all instances of id to class, and change the hash/pound signs to periods, and all will be fine.


    css doesn't work in netscape 4.x as far as i know
    NN4 has decent support of CSS1. Not a whole lot, but enought to keep a page decent looking.

    i also know that some versions of netscape, don't work CSS if you include it in a style sheet separate from your HTML page, so in all my pages, i just have the CSS in the header, no link to a CSS file.
    Wrong, you lose. NN4 does support external style sheets. A major benefit of using style sheets is that you can link all your pages to just one CSS file.

  8. #8
    hell no, we won't go!
    Join Date
    Sep 2002
    Posts
    1,093

    Re: Re: CSS Not Showing Up in NS4.7

    Originally posted by Tim
    NN4 doesn't recognize the id attribute. Change all instances of id to class, and change the hash/pound signs to periods, and all will be fine.
    Thanks! I'll skip the usual "NS Sucks" and just going on my marry (out of the) way to make sure everyone can see the site.

    I still don't understand why it won't show my p style though...
    - Colin

    I like food.

  9. #9
    Loyal Client
    Join Date
    Jan 2002
    Posts
    636

    Re: Re: Re: CSS Not Showing Up in NS4.7

    Originally posted by Dogma

    Thanks! I'll skip the usual "NS Sucks" and just going on my marry (out of the) way to make sure everyone can see the site.

    I still don't understand why it won't show my p style though...
    Dogma... I was doing a bit of reading up on netscape and css,
    thought you and others may like to read this article

    You all may of read this months ago, but if not... I feel it may offer a solution. With a sorta nice way of saying to the end user with outdated browsers....."Hey you... GET WITH IT ALREADY!"

    Lot of things I am not sure of yet, but this browser thing... I know for certain, will be a thorn for a long time to come!

    Even read an article at sitepoint of designing with no tables at all... using <div> and schtuff... go figure.
    Tables Rule!!!

  10. #10
    Tim
    Tim is offline
    Loyal Client
    Join Date
    Mar 2002
    Location
    Nevada, USA
    Posts
    152

    Re: Re: Re: CSS Not Showing Up in NS4.7

    Originally posted by Dogma
    I still don't understand why it won't show my p style though...
    Ah ha! I've got it figured out now. In addition to the aforementioned changes, remove that voice-family junk. That is what is causing NN4 to not render the rest of your style sheet. I think that hack is unnecessary, and have never encountered a need for it.

  11. #11
    hell no, we won't go!
    Join Date
    Sep 2002
    Posts
    1,093

    Re: Re: Re: Re: CSS Not Showing Up in NS4.7

    Originally posted by Tim
    Ah ha! I've got it figured out now. In addition to the aforementioned changes, remove that voice-family junk. That is what is causing NN4 to not render the rest of your style sheet. I think that hack is unnecessary, and have never encountered a need for it.
    Is that it? It's in there because of NS/IE Box Model differences (NS does it right, IE does it wrong.) I'll see if I can't get around that though...

    Thank you so much!!
    - Colin

    I like food.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •